Php Kurulumunuzda WordPress’in Çalışması İçin Gerekli Olan Mysql Eklentisi Eksik Çözümü!

Spread the love

WordPress kurmaya çalıştığımızda aldığımız bir hata/uyarı ile ilgili olacak.

Hata mesajımız WordPress dosyalarımızı ftp ye attıktan sonra tarayıcıya geçip kurulumu başlatmaya çalıştığımız sırada karşımıza “php kurulumunuzda wordpress’in çalışması için gerekli olan mysql eklentisi eksik” olarak çıkıyor.

Bildiğiniz üzere WordPress son zamanlarda artık iyice popüler olmuş ve kendi kategorisinde zirvede olan bir içerik yönetim sistemi ( cms ) dir. WordPress ve WordPress için geliştirilmiş olan binlerceeklenti ile her türlü siteyi yapabilmekteyiz. Tabi ki belli bir bilgi seviyesi olması gerekiyor.

Aksi takdirde bu makalede üzerinde duracağımız gerekli olan mysql eklentisi eksik hatasına benzer daha pek çok hata ile karşılaştığınızda çözüm bulmak sizi zorlayabilir. WordPress ile ilgili hatalar bazen yazılımsal yani eklenti kaynaklı, WordPress dosyalarından/sürümünden kaynaklı veya kullanıcının yaptığı hatalardan kaynaklı olabildiği gibi, bazen de hizmet aldığınız hosting sağlayıcınız taraflı olabiliyor.

Bu yüzden hosting sağlayıcıları sorunlarından kendilerinden kaynaklı olmasını en aza indirmek amaçlı WordPress için en stabil şekilde çalışabileceği hostingler üzerinde çalışmakta ve buna da son zamanlarda WordPress uyumlu hosting adını vermektedirler.

WordPress Kurulumu İçin Gerekli Php Ayarları

Şimdi gelelim artık yavaş yavaş esas konumuza. Çok heyecanlısınız belki ilk sitenizi belki de önemli bir projenizi yapmak üzere WordPress dosyalarınızı ftp alanınıza yani hosting inize yüklediniz ve WordPress kurulumunu çalıştırmak için site adresinizi tarayıcıya yazıp sitenizi çağırdınız bir de baktınız ki o ne! Boş beyaz bir sayfada ekranın üst tarafında sadece “php kurulumunuzda wordpress’in çalışması için gerekli olan mysql eklentisi eksik” yazısı yazıyor. Şimdi işin gücün yok ise bu sorunu çözmeye uğraş.

Arkadaşlar bu sorun kullandığınız Cpanel veya Plesk panel de bir ayarın yanlış yapılandırılmış olmasından kaynaklanmaktadır. Ancak bu ayarı siz yaptınız demiyorum. Bu ayar genelde bazı hosting firmalarının hatasıdır. Peki bu sorunu nasıl çözeceğiz ? gelin hep birlikte öğrenelim.

WordPress mysql eklentisi eksik hatasının çözümünü göstermek için biz Plesk panel üzerinden anlatım yapacağız. Ancak Cpanel kullanan arkadaşlar da aynı ayarları panellerinde bulabilirler. Öncelikle sitenizin Plesk paneline giriş yapın. Plesk panele giriş yaptığınızda orta kısımda bulunan barındırma ayarları kısmına giriş yapınız.

Arkadaşlar yukarıdaki Php Desteği kısmını bulduğunuzda sizde php versiyonu Fpm olan bir seçenek ve sağ taraftaki php yi farklı çalıştır kısmında da Fpm uygulama Nginx tarafından sunulur yazıyor olabilir. Eğer bu şekilde ise bunu php desteği fpm dışında olan eğer fastcgi var ise bu seçeneklerden birini yok ise fpm dışındaki diğer php versiyonlarından biri ile değiştirmeniz gerekmektedir.

Buradaki önemli nokta php versiyonu kısmını değiştirdiğinizde hemen yan taraftaki php yi farklı çalıştır kısmınında değişmesi gerekir. Eğer değişmiyorsa el ile o kısmı da değiştirin ve ayarları kaydederek WordPress kurulumunuzu yeniden deneyin.

Eğer sizde zaten en başından bu ayarlar fpm değil veya bu ayarları uygulamanıza rağmen sorun çözülmedi ise şimdi anlatacağımız 2. ayarı uygulamalısınız. Yeniden Plesk panel ana ekranına döndüğünüzde ekranın sağ kısmında Php Selector menüsünü göreceksiniz.

Bu menüye girdiğinizde php versiyon kısmında Native yazdığını görmeniz muhtemeldir.

Çözüm olarak Native yazan seçeneği php nin stabil olarak çalışan versiyonlarından biri olan 5.4 ile değiştirmeniz ve ayarları kaydetmek için önce yandaki set as current butonuna ve sonrasında alt kısımdaki save butonuna basmalısınız. Bu ayarları yaptıktan sonra yeniden sitenize giderek WordPress kurmayı denediğinizde sorunun giderildiğini göreceksiniz.

Önemli Güncelleme; Eğer yukarıdaki çözümleri uygulamanıza rağmen halen problem devam ediyor ise Plesk veya cPanel anasayfasında Barındırma Ayarları seçeneğine yeniden girin. Barındırma Ayarlarının alt kısmında SSI desteği ve CGI desteği kısımlarının aktif/seçili olması gerekir. Eğer bu seçenekler işaretli değilse işaretleyin ve ayarı kaydedin. Son olarak işleminizi yeniden deneyin. Muhtemelen problem giderilmiş olacaktır.

Bir cevap yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

This site uses Akismet to reduce spam. Learn how your comment data is processed.